Search Issue Tracker

Fixed in 2017.3.0f3

Fixed in 2017.1, 2017.2

Not Reproducible in 5.6

Votes

0

Found in

2017.1.0p1

Issue ID

934735

Regression

Yes

Android build fails but "Build completed with a result of 'Succeeded'" message is shown

Mobile

-

How to reproduce:
1. Open the attached project
2. Set "Android" as the current target
3. Set "Gradle" as the build option
4. In player settings > publishing settings set existing keystore (you will find it in the project ../Keystore/TestKeyStore.jks , password is Unity77) or create a new one
5. Build the project

Actual result: Build fails, but one can see in Console (2017.2) or Editor.log "build succeeded" message
Expected result: if build fails, it shouldn't write that it succeeded

Reproducible: 2017.1.0p1, 2017.2.0b4, 2017.3.0a1
Not reproducible: 5.6.2p3

Same issue when building with Gradle or Internal build system

Comments (2)

  1. 603eb86ac39c3e8e6b29a87ca56f932a?d=mm

    pako

    Sep 02, 2018 21:40

    Same error Unity 2018.2.6f1.

    However, BEFORE the "build succeeded" message, there were 2 error messages:

    Failed running C:\Program Files\Unity 2018\Editor\Data\il2cpp/build/il2cpp.exe --convert-to-cpp --emit-null-checks --enable-array-bounds-check --compile-cpp --libil2cpp-static --platform="Android" --architecture="ARMv7" --configuration="Release" --outputpath= ...

    and

    Exception: C:\Program Files\Unity 2018\Editor\Data\il2cpp/build/il2cpp.exe did not run properly!

  2. 12701ed09486b49049bf4cd47ea628ff?d=mm

    awais503

    Jul 10, 2018 05:46

    Again same error in unity 2018.2.0b.11..

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.