Search Issue Tracker

Fixed in 2.1.0-preview.5

Votes

0

Found in [Package]

preview.4 - 2.0.2

Issue ID

1155073

Regression

Yes

[Android][ARCore][AR Foundation] black screen on Android when using IL2CPP

Package: ARCore

-

Steps to reproduce:
1. Open attached "arbug.zip" project
2. Build and run on Android
-black screen on the device

Expected result: Should open the front camera and display it in the app
Actual result: App displays a black screen

Reproduced on: 2019.1.2f1, 2019.1.4f1, 2019.3.0a1, 2019.3.0a3

ARCore XR Plugin:
preview.4 - 2.1.0 repro
preview.4 - 2.0.2 - repro
preview.24 - 1.0.0 - no repro

Note: read edit for more information.

The workaround is to modify the link.xml to
<assembly fullname="Unity.XR.ARCore" preserve="all" ignoreIfMissing="1"/>
(note preserve="all" instead of "none")

Devices under test:
VLNQA00218, Samsung (SM-N960U), 8.1.0, CPU: Snapdragon 845 SDM845, GPU: Adreno (TM) 630
VLNQA00001, Google Pixel 2 (Pixel 2), 9, CPU: Snapdragon 835 MSM8998, GPU: Adreno (TM) 540

Comments (3)

  1. 6c91e535171501237eb6bfa5e698affd?d=mm

    marck_ozz

    Nov 28, 2020 01:36

    Where should be that "Link" file and why is not un my project? Unity 2019.4.12, Tested with ARF 2.2, 3.6, 4.1 and their corresponding ARCore version

  2. 8b731baef2f2c8cfa0b2dca8f0bace70?d=mm

    taynaTinoco

    Jul 21, 2020 15:36

    I'm having this issue using unity 2019.4.01, Ar Foundation 2.1.8, AR Core XR 2.1.8 on a Samsung Galaxy s7

  3. 3b28023384de22b3484823c9bb1fcbd7?d=mm

    dantesryu

    Mar 25, 2020 09:59

    I got the black screen problem on Unity 2019.3.6

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.