Search Issue Tracker

Status: Fixed in Unity 5.6.0

Votes

8

Found in

5.3.4f1

Issue ID

783535

Regression

No

Accessing AnimationClip properties in runtime throws MissingMethodException on some platforms

Animation

-

-

Priority: 4Not yet prioritized for a release

-

Severity: 3Workaround is possible

Steps to reproduce:

1. Open attached project "783535.zip"
2. Open scene "repro"
3. Run it
4. Notice "False" printed in console. We get it by simply creating new animation clip and logging isLooping value
5. Build and run standalone in development build
6. Notice MissingMethodException on the screen
7. Build and run WebGL build
8. Open browser console
9. Notice that False is printed

Reproducible on: Windows standalone, Mac standalone
Not reproducible: WebGl, Editor

Reproduced with: 5.2.4f1, 5.3.4p1, 5.4.0b12

Comments (5)

  1. 39204c2c77f04124a4748cd8eb2ccd4d?d=mm

    Markaz

    Dec 13, 2016 14:00

    Reproduced in 5.3.5p8

  2. 44957668cf6f02cd432feccd16d6c7ad?d=mm

    arai_takahiro

    Aug 18, 2016 07:20

    Reproducible on: Android
    Not reproducible: Editor, iOS

  3. 44957668cf6f02cd432feccd16d6c7ad?d=mm

    arai_takahiro

    Aug 18, 2016 07:18

    Reproduced in 5.3.6f1

  4. C2821b4b0ce7daeaffbbd57d19f39460?d=mm

    norifumi-okumura

    Aug 08, 2016 09:46

    Reproduced in 5.3.4p4

  5. 77a6b8fb34024aed283f9491e5c52c58?d=mm

    jkramar

    Jul 19, 2016 17:05

    Reproduced in 5.3.5f1

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.