Search Issue Tracker

Won't Fix

Votes

167

Found in

5.0.0b19

Issue ID

662813

Regression

No

[Geomerics] Stuck at clustering jobs when baking lightmaps.

Global Illumination

-

-e: attached project never finishes baking

-repro:
--open attached project (it is https://www.assetstore.unity3d.com/en/#!/content/9473)
--open the "scene" in the JunglePack
--open lighting window
--start the backing
--NOTICE it gets stuck at "5/11 clustering"
---it was running two JobProcesses at max for over 1h and logged nothing into the the editor log
--cancel bake
--change color space to linear in player settings
--start baking process
--NOTICE it gets now stuck at "7/11 Light Transport"

--would be really nice to have some extra indication as to whether it is actually still doing something and not just spinning

  1. Response avatar

    Resolution Note:

    We won't be fixing Enlighten-related issues as it has been deprecated. Please consider using Progressive CPU or GPU Lightmappers instead.

Comments (126)

  1. 081d74793e29a21e5b5bb44fac6b0df2?d=mm

    houserrob

    Jul 09, 2016 21:19

    Hitting this as well on 5.3.5f1 :( I had to switch from a Unity Terrain because mobile perf was awful now my 16K mesh that I put in to the replace the Unity Terrain baking is failing at the 5/11 of step. I've let it run for a couple of hours to no avail. I know for certain it's the new terrain replacement mesh causing it. I might be able to get away with realtime lighting but this is a pretty bad bug.

  2. Ad9336d681dc3f1a1409f28279678382?d=mm

    essimoon2

    Jul 08, 2016 12:13

    My bakes still fail with one clustering job remaining no mater how often I clear or relocate the cache, open a new scene or even download a new version of Unity..
    I hope this issue gets a bit more attention, I can't bake my lighting at the moment :/

  3. 676a4d9658f0e6cdbb6da45ce7980ee0?d=mm

    joseit

    Jun 17, 2016 01:35

    Baking in Unity gets stuck on 5/11 when some static objects' scales are too large.

    A common example is a default static plane scaled above a certain size. Either reduce its scale or un-check its static box in the inspector. Then it'll work.

  4. 3d11c87e9e7ce9eeb4181f64928fa3ec?d=mm

    mos

    May 26, 2016 16:25

    Same problem. Baking keeps stuck in 5/11 Clustering 1 job forever... Baking with big meshes doesn't work in Unity 5.

  5. 84c95a59aa647a3148aba6c18b5bf63d?d=mm

    Mike Cotton

    May 18, 2016 18:34

    Also having issues with GI

  6. 4b03bfe7ed99ecf7297d9bc86345ab20?d=mm

    hsdxpro

    May 15, 2016 21:17

    Hi !

    I used UE4 for months, the worst public engine ever made with lot of bugs, crashes, and missing usable C++ interface for programmers.

    Unity is better, and more stable, but don't fall into the trap UE4 does. At a certain engine code & feature complexity there should be less new features & refactor, than BUG FIX.

    100 - 200 people voted to fix this bug, but 10000 - 20000 people want other bug fix?
    So you guys fix the 10000 - 20000 voted bug?

    What if 100 - 200 people are real developers with very big sale & money potential, bigger than 10000 - 20000 people?

    If this isn't true, then I say nothing. But tell me which product's team want to tweak the lightmap and their settings?. A prototype project with some placeholders in the beginning stadium, or the other, think about it. Thanks.

  7. 1f78ed66b4cb51e92c94b3e6fdaf45aa?d=mm

    sebastiansgames

    May 02, 2016 17:26

    The fact that lightmapping is basically broken in Unity is ridiculous. We have a pretty large arch previs scene that crashes every time we try to bake. We keep dropping the baked resolution to no avail. To describe this as a catastrophe would be an understatement.

  8. 8de4680dd64ee7052875df47475871e3?d=mm

    The Beach

    May 01, 2016 01:02

    I got the same problem on my scene, i managed to fixed it by deleting the object that was blocking the Clusterizing. It wasn't hard to find but rather long and boring... So i duplicated my scene and deleted one type of object at a time, and each time I tried building the lights. If the clustering stopped at a job more than 10-20 seconds(depend of your config) i keep deleting objects. Until i found the one. Very small and common object btw, not the fancy big scaled plane described by someone on the thread.

    So i finally opened back my real scene and deleted those objects. And the baking was fine after that !

    I guess the GameObject just got corrupted .. Somehow

  9. 20bd6b2fdd87a2720f56e79799baf81c?d=mm

    cooperm211

    Apr 26, 2016 03:27

    I had this issue for the longest time and I found something that seems to work... I'm not an expert by any stretch of the imagination but try creating (in the project folder) a Lightmap Parameters thing.

    Click on it in the project window and in the inspector knock the resolution way down (I did 0.1) and also try dropping anything under Baked GI down too. Then, while you have objects in your scene selected, click the Lighting tab, click the Object tab (under lighting) and change the advanced parameters to use the custom Lightmap Parameters thing you just made. That will get the object to use some sort of scaled down UV.

    That worked for me (since I think it's all related to some weird scaling bug). Try scaling the settings way down and just see if you can get the clustering to complete and then creep it back up. This had been driving me crazy since they first introduced the PBR lighting. Good Luck!

  10. E67c518e457c3404cf5dacd90c29434b?d=mm

    Darth-Zoddo

    Apr 11, 2016 11:56

    makes me contemplaint switchin to UE4....... thanks to this i can't optimize my game and finish it. Hope it gets fixed soon.

    I feel bad for companies that rely on this, they must be losing money for not being able to release their games....

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.