Search Issue Tracker

Won't Fix

Votes

167

Found in

5.0.0b19

Issue ID

662813

Regression

No

[Geomerics] Stuck at clustering jobs when baking lightmaps.

Global Illumination

-

-e: attached project never finishes baking

-repro:
--open attached project (it is https://www.assetstore.unity3d.com/en/#!/content/9473)
--open the "scene" in the JunglePack
--open lighting window
--start the backing
--NOTICE it gets stuck at "5/11 clustering"
---it was running two JobProcesses at max for over 1h and logged nothing into the the editor log
--cancel bake
--change color space to linear in player settings
--start baking process
--NOTICE it gets now stuck at "7/11 Light Transport"

--would be really nice to have some extra indication as to whether it is actually still doing something and not just spinning

  1. Response avatar

    Resolution Note:

    We won't be fixing Enlighten-related issues as it has been deprecated. Please consider using Progressive CPU or GPU Lightmappers instead.

Comments (126)

  1. 8a77d3aadf4ebb2d16d7674e0d904fcc?d=mm

    pfisher1

    Apr 09, 2015 21:11

    I had the same problem with 5.0.1 and unchecked compressed under baked GI and finally it works!

  2. 289a8c80e2f2b19ba2dc9fb28d8046a2?d=mm

    jpv1234

    Apr 08, 2015 02:30

    I dont know if this heps but in my case I could get around this problem by changing the Indirect Resolution in Baked GI. Before I was at 2 texels per unit and Unity was stuck at clustering. However when I changed that value to 1 it worked like kind of magic. The baking was strange since the scene was darker than expected, but it worked finally.

  3. 289a8c80e2f2b19ba2dc9fb28d8046a2?d=mm

    jpv1234

    Apr 08, 2015 02:16

    Having same annoying problem with 5.0.04f. My lightmaps were taking like 5 minutes in Unity4 and now they take almost 50 minutes and is stucked in clustering with 1 job

  4. 3f5d48ffb3f2164ec4edd520afbca649?d=mm

    xzbobzx

    Mar 28, 2015 21:35

    Yup - same thing.

    All my lighting is messed up, I can barely work on my game like this.

    Any solutions?

  5. B7c29b0df0da66b968cc712e70095119?d=mm

    Nimbuster

    Mar 28, 2015 15:44

    Update: I waited a few minutes and resumed the processes. CPU usage dropped to 35-75% and the jobs finished in a couple minutes.

  6. B7c29b0df0da66b968cc712e70095119?d=mm

    Nimbuster

    Mar 28, 2015 15:37

    Happening for me with the Stealth tutorial project on Unity 5.0.0f4. When I add the environment asset, it starts running the jobs and hangs. I thought it was my computer and made that my excuse for upgrading. Now I am running 8 4.0 GHz cores, 16 GB memory, and a Radeon R9 270X... but same problem. It seems to hang at "5/11 clustering" for a few minutes at about 70% of my CPU, then at "7/11 Light Transport", and then on "7/15 Bake Direct" it pulls 100% of my CPU and doesn't seem to make any progress. I eventually suspended the processes.

  7. 15f9295b2169ae43ba3eac97d88408c5?d=mm

    _M_S_D_

    Mar 23, 2015 08:27

    I have the same issue. I have a pretty big scene with many low tri (50-300) static objects. Had no issue baking lightmaps before, then suddenly just stopped working.

  8. 923d9fe8de730cb246567d736915c924?d=mm

    Jordan104

    Mar 23, 2015 08:09

    Really annoying problem, hopefully unity addresses this issue soon.

  9. 383ea573593ff446ecac50a4fcc49137?d=mm

    Iron-Warrior

    Mar 20, 2015 04:50

    Same issue here, 5/11 Clustering | 1 Jobs. Single static object in the scene, ~700 tris. Unity 5.0.0f4.

  10. 9c1c276d6b4dca7823da5af5a9a66010?d=mm

    Anjin_nz

    Mar 16, 2015 11:15

    Currently sticking on rendering a terrain and on a very large plane > 12 in scale.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.