Search Issue Tracker

Postponed means that the issue was either a feature request or something that requires major refactoring on our side. Since that makes the issue not actionable in the close future we choose to close it as Postponed and add it on our internal roadmaps and technical debt pages instead.

Postponed

Votes

167

Found in

5.0.0b19

Issue ID

662813

Regression

No

[Geomerics] Stuck at clustering jobs when baking lightmaps.

Global Illumination

-

-e: attached project never finishes baking

-repro:
--open attached project (it is https://www.assetstore.unity3d.com/en/#!/content/9473)
--open the "scene" in the JunglePack
--open lighting window
--start the backing
--NOTICE it gets stuck at "5/11 clustering"
---it was running two JobProcesses at max for over 1h and logged nothing into the the editor log
--cancel bake
--change color space to linear in player settings
--start baking process
--NOTICE it gets now stuck at "7/11 Light Transport"

--would be really nice to have some extra indication as to whether it is actually still doing something and not just spinning

Comments (126)

  1. C35b9264646fd1b72f6ccfca2622c409?d=mm

    AlanMattano

    Nov 17, 2017 14:55

    Unity 5.6 2017

    5/11 cluster | 1 job still not done (in progress) when adding a big 128 scale plane into the scene.

  2. 2ecf334009b92b39a70f56ebb70d5374?d=mm

    jeffreylmeyer

    Sep 11, 2017 01:12

    I am having same issue, completely freezes the program when lighting starts to calculate, does it in 5.5.4 and 2017, worthless editor

  3. 2c8db65a14d35e7d3efe5711c0082fa7?d=mm

    micktravels

    Jun 19, 2017 04:10

    I was having the same annoying problem on 5.6.1. Fixed it by changing Lightmapper in the Lighting Window from Enlighten to Progressive. I imagine that's why this issue is marked as Postponed - because it is unique to an older lightmapper and they don't need to go back and fix it.

  4. F7f0d04a722d698de71aadfb2c06e8bc?d=mm

    2007michaeleh

    Jun 18, 2017 02:25

    Yeah, plus you can't build the normal way if it keeps getting stuck on one part of the baking process! :(

  5. 0adce14c99c2ef5fe7723ee82510cb41?d=mm

    EMClick

    Apr 03, 2017 15:42

    is unbelievable from version 5.0 to 5.6 there is no fix for this issue, so many reports. Is relationed to some exhaustive task.

    In my case, I lower the resolution of Lightmap Parameters to Default-LowResolution and LightmapSize to 256 and started to walk again but this should not be.

    Please do something about it

  6. 064d802e52fc663fb6c006845af9a38b?d=mm

    FountainaGoat

    Mar 09, 2017 22:08

    What solved this issue for me was switching to UV charts view and adjusting the lightmap resolution in light mapping settings and each meshes "scale in lightmap" parameter until they were reasonable. The default lightmap resolution parameter for my scene was 40 which was way too high.

  7. 04b4cb9840843b4f29eb3002d75acbab?d=mm

    Seraphic572

    Mar 06, 2017 16:04

    When will this issue get addressed ?

  8. 3e08aa4f6aa45fcf58d782dbccb180b4?d=mm

    HeyMufti

    Mar 03, 2017 00:41

    Error still persists. Lightmapping is a complete mess in Unity 5.5. Fix or I'll be forced to port the project to UE4.

  9. 6cbf55bfaf4555981245f5edeb3b2f67?d=mm

    HaakonL

    Feb 27, 2017 12:48

    Oh my. I guess this will be fixed as part of the new Unity 2017 after the summer, to force everyone to upgrade ;)

  10. 1a41ce8a4838b2808a511734574b033f?d=mm

    Zihaben

    Nov 15, 2016 21:35

    Have the same problem.
    In my case, that was caused by STATIC GAMEOBJECT WITH SHADOW CASTING TURNED OFF. So I turned on shadows for all the gameobjects, and everything is OK.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.