Search Issue Tracker

By Design



Found in


Issue ID




[LoadSceneAsync] allowSceneActivation flag is ignored in Awake()

Scene Management


Repro steps:
1) Open the project and scene Awake in it
2) Play and notice that exception appeared (ERROR ERROR ERROR)
3) Stop and load scene Update
4) Play - notice there is no exception
5) Stop - notice the exception appears

Workaround: Use Start() or Update() to load the scene

Repro in: 5.4.0b1; 5.3.1p1; 5.2.3p3; 5.1.4f1

Comments (18)

  1. 8d6089d4f771439b8b27e4692975ed75?d=mm


    Aug 04, 2020 20:08

    In 2018, you could get around this by starting a coroutine and waiting one tick. This workaround no longer works for 2019.

  2. 5c9e21eefeb8f652abf8953d4e8730b7?d=mm


    Jun 28, 2020 20:08

    It seems to work for me with an IEnumerator Start

    IEnumerator Start()
    yield return new WaitForSeconds(0.2f);

  3. D83e184bf200adb97d8c375f9a70db8b?d=mm


    Jun 17, 2020 19:13

    In unity 2019.4 it's not working AT ALL! Not in Update, Start or in Coroutine. Not fixing a clear bug since 2017 is shameless!

  4. 7a3073409ab6290326509a6172648144?d=mm


    Jun 10, 2020 20:59

    On 2019.3, June 2020, still not working. Tried Start() and Update(). Neither work!

  5. C72216e7cf21f3690aedd50f44ba3f52?d=mm


    May 07, 2020 11:40

    Do you have any updates?

  6. 6b9ac7beff7115aee69165fa78bbbe06?d=mm


    Feb 17, 2020 00:30

    Thanks, wasted quite a bit of time on this design choice.

  7. C652235dd0b662a0ee928c3260710ec5?d=mm


    Dec 20, 2019 09:09

    How is this "By Design"?

  8. 4ae56b6b29cc6e9f4fd631010c4f926b?d=mm


    Jul 24, 2019 19:54

    I'm going to be bumping this, as it appears that the bug is not fixed yet in the editor. I'm using a coroutine to start loading a scene async, but .allowSceneActivation = false is being ignored.

  9. E053f5713a2050e21e4a8f56bf805203?d=mm


    Jul 04, 2019 10:36

    This is still an issue (at least in the editor).

    Please fix or mention it in the documentation !

  10. C4e5068818b584c26a8fccb230ba22ac?d=mm


    Jun 02, 2019 18:21

    I have it in 2018.3.12f1.

    I added a small artifical delay, it helped.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.