Search Issue Tracker

Fixed in 2017.1.0f3

Fixed in 5.6.X



Found in


Issue ID




Errors message at editor play

Graphics - General


Errors message at editor play

Repros: open scene1 press play in the editor and see following errors in the console:

In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first.

In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first.

fix in progress in this PR

Comments (118)

  1. 908e1e4e345cad89336815e569706e6e?d=mm


    Apr 07, 2017 11:38

    Still here in 5.6.0f3

    Maybe time for fixed?

  2. F854ad6566e9afc2a6b564c75ac52c4b?d=mm


    Apr 07, 2017 08:13

    Still here in 5.6.0f3. Shows up whenever rigidbodys are set to interpolate.

  3. 3d2e79aeeefdf9ff02996d008dc58012?d=mm


    Apr 06, 2017 20:50

    Is anyone at Unity still working on this? It's marked as resolved, and voting is disabled, but clearly a number of people still have this problem in the release version (5.6.0f3). I'm not seeing any new bug reports though, even though I filed one myself a few days ago. This is still the only hit I get when I search for this problem.

  4. 29a0a6c72cf3d87617183a65d1ff80b4?d=mm


    Apr 06, 2017 16:44

    My solution sadly did not hold, BUT I found a SOLID way to reproduce this bug.
    It isn't rigidbodies, perhaps that was it during the beta version but you can reproduce easily now even on a brand new project with NOTHING inside on the "stable" release of 5.6.0f3 following these steps.
    Took me a painstaking amount of time toggling components to narrow this down.
    I filed a bug report so will be helpful if you guys voted on it. Will post back once the report is verified
    Try the steps I mention and you'll see :)

    1. Create a brand new project, lets start fresh.(no need to import anything)
    2. In the scene, create a Spotlight > Change "Shadow Type" to "Soft Shadows"
    3. Keeping that Spotlight selected > Create > 3D Object > Cube (to make it a child of the light)
    4. Change Cube's position to (0, 0, 1)[x, y, z] {so it is directly below Spot Light}
    5. Add "Skinned Mesh Renderer" component to this Cube. (leave Mesh Renderer as is)
    6. Keeping this Cube selected > Create Empty Child (creates empty GameObject as child of Cube)
    7. Select Cube, drag the empty GameObject to the "Root Bone" of the "Skinned Mesh Renderer" component.
    8. In the Scene View, making sure the cube is visible, toggle "Skinned Mesh Renderer" rapidly and if everything was done right, you should see the following error message
    "In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first."

    The important elements of this bug reproduction are Spotlight, Realtime/Mixed Shadows(hard/soft), "Skinned Mesh Renderer" with "Root Bone" assigned.

  5. F413441f3d1a817646ca6cb56466cad1?d=mm


    Apr 05, 2017 14:54

    Still happening in Unity 5.6f3 , wasn't happening in Unity 5.5

  6. 2c77da3d1d53514294331467d2589139?d=mm


    Apr 05, 2017 12:08

    I've got this issue, too, on Unity 5.6.0f1 Linux.

    For me, a mirror plane (of the non-rendertarget veriety) seems to the be issue. The mirror stopped working and whenever it enters the camera, I get the warning once (and then only again when it was off-camera for a moment).

  7. 29a0a6c72cf3d87617183a65d1ff80b4?d=mm


    Apr 05, 2017 04:41

    SOLVED IT!!! (For me at least)

    In case this helps anybody else out, here's what I did and it went away like magic!

    I checked all my Rigidbodies, and ALL of them had Interpolation set to none, even the instantiated prefabs. So that wasn't the solution.

    But then the STRANGEST know that quarky little check box that appears about "LINE ENDINGS"?? That thing that's different about MAC and Windows...apparently that was it for me.
    The error appeared right from play start, so I opened my main player script for the first time on 5.6 and sure enough, the check box appeared. I hit ok, saved and poof, gone for player. But next I went in to a battle mode (mine is a indie Pokemon game) and I chose Pikachu and then it was causing the error. I exited playmode, did the same with him and poof!

    So naturally I clicked on the drop down menu on Project window right next to the search bar and selected "scripts", selected all, hit enter to open fire on Visual Studio. It was a rapid succession of that silly Line Ending Windows CL..something showing up, me hitting yes. Good game.
    Finally when the battles were won, I simply hit "Save All" on VS, closed it. Saved scene + project. Hit play, and the error was no more. The end :)
    Again, this worked for me, the Rigidbody thing worked for other people. Worth a shot am I right?

  8. 92b5a14be31ef0d7f752ac761116248f?d=mm


    Apr 04, 2017 20:38

    I'm getting this error when the camera turns towards particle system objects

  9. 41a594213ecbcd4d75f4abfb32719d18?d=mm


    Apr 04, 2017 17:29

    If you're using Steam VR, you'll need to edit line 167 on Throwable.cs

    rb.interpolation = RigidbodyInterpolation.None;

    Still an issue with 5.6.0f3 so this shouldn't be closed.

  10. 41a594213ecbcd4d75f4abfb32719d18?d=mm


    Apr 04, 2017 17:24

    This is still an issue in 5.6.0f3

    - Using SteamVR
    - All rigidbodies interpolation set to none

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.