Search Issue Tracker

Fixed in 2017.1.0f3

Fixed in 5.6.X

Votes

21

Found in

5.6.0b8

Issue ID

879941

Regression

Yes

Errors message at editor play

Graphics - General

-

Errors message at editor play

Repros: open scene1 press play in the editor and see following errors in the console:

In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first.

In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first.
UnityEditor.DockArea:OnGUI()

fix in progress in this PR

https://ono.unity3d.com/unity/unity/pull-request/41589/_/animation/case879941

Comments (118)

  1. 31b1c20e5168001902d5234006186ec4?d=mm

    dgoyette

    Jun 11, 2019 15:37

    I suddenly started getting this error in 2019.1.4, after having been using that version of Unity for several weeks without getting this error. It started occurring around the same time that I started having Unity crash fairly often doing completely normal things in the editor. Interesting, the crash reports I was getting, as well the error message in this issue, generally complained about some kind of OnGUI occurrence.

    I believe the root cause of these kinds of issues has to do with some kind of corruption of the editor Layout. When I start seeing crashes, or errors like this, Igo to "Window -> Layouts -> Revert Factory Settings..." and delete the layout. After doing so, I stopped getting this error entering playmode.

    So, for those still experiencing this issue in 2019+, try to delete your layout, and see if that helps.

  2. Bc75b90edcac1ec26cfd78a350b44d9f?d=mm

    fherbst

    Jun 11, 2019 11:03

    Still happening in 2019.2.0b4, didn't happen in 2019.2.0b3 and earlier.

  3. 1f78ed66b4cb51e92c94b3e6fdaf45aa?d=mm

    sebastiansgames

    Feb 19, 2019 23:03

    still seeing this in 2018.2.20f1

  4. E9645e81c8751b7bf62d3c208ac34286?d=mm

    Mamesza

    Feb 06, 2019 16:56

    Hello, I got: "In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first."
    I can see this error when using tilemaps.

  5. 4a4be7fa25d6b89554c57a3d3d9df399?d=mm

    WenDaoSheng

    Nov 16, 2018 05:01

    unity 2019.2.16 The error still exists.

  6. F4a35df73920e3bab912343bc00d09ec?d=mm

    Willkuerlich

    Oct 07, 2018 21:52

    Stil have this or similar issue with Unity 2018.2.8.1in playmode. Started yesterday using UnityEngine.Tilemaps namespace components in my scene

  7. 7d42c95eec4c088f5d19ed855c8f1737?d=mm

    ahstein

    Jul 24, 2018 21:18

    I am also encountering this error in version 2018.2.0f2.

  8. D1af97f40f62027e14a5beddf4eab9e4?d=mm

    Brandooh

    Jul 24, 2018 14:54

    I'm getting this error with Unity 2018.2.0f2. Is there no workaround or solution?

  9. 3338b27654f7fef154a78e3567828e10?d=mm

    DangerouZ720

    Dec 27, 2017 15:55

    still not fixed on version 2017.3.0p1

  10. 33699df224e63952a7d0fa89216d7503?d=mm

    Albertomelladoc

    Nov 03, 2017 10:04

    This issue is still happening in 2017.1.0f3, 2017.1.1f1 and 2017.3.0b1 for me.

    Error message -> Assertion failed: In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first.

    The errors dont prevent execution or cause any trouble, but they are pretty annoying.

    Best Regards

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.