Search Issue Tracker

Fixed in 2017.1.0f3

Fixed in 5.6.X

Votes

21

Found in

5.6.0b8

Issue ID

879941

Regression

Yes

Errors message at editor play

Graphics - General

-

Errors message at editor play

Repros: open scene1 press play in the editor and see following errors in the console:

In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first.

In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first.
UnityEditor.DockArea:OnGUI()

fix in progress in this PR

https://ono.unity3d.com/unity/unity/pull-request/41589/_/animation/case879941

Comments (116)

  1. 3361a352d9e72c7c299a093fad471e91?d=mm

    Johannski

    Mar 31, 2017 16:10

    Still appearing in Unity 5.6.0f2

  2. 471bcbbec345abc90f0af904ff697e1f?d=mm

    cAyouMontreal

    Mar 24, 2017 13:21

    Issue still there in 5.6.0b11.

  3. 38f7c2e090482ca69268050474032d4f?d=mm

    josephquested

    Mar 22, 2017 04:51

    I am still getting this error in 5.6.0b11. However, it doesn't seem to be doing anything. Nothing that I can notice anyway.

  4. 58d6dfe6a233a018e8ffd07d64c602df?d=mm

    pragmascript

    Mar 20, 2017 00:14

    _NOT_ fixed for me in 5.6.0f1

  5. 7b328696dc5caae88b50a4c0afd62a1e?d=mm

    MrDVolo

    Mar 19, 2017 13:17

    Agree with 'RODOLPHITO', not fixed in 5.6.0f1.
    'Fixed in Unity 5.6.0' meaning fixed in official release (currently internal)?

  6. 70ac6eac46c0141d407b0d91b545d556?d=mm

    Rodolphito

    Mar 18, 2017 02:39

    Still in Unity 5.6.0f1

  7. 804ffc3f18a331d8dfa710b06a307cd1?d=mm

    SmashedAvocado

    Mar 16, 2017 01:39

    After some pain: Workaround seems to be to set "Interpolation: None" on some or all rigid bodies.

    I had about 20 boxes with Interpolation: Extrapolate, and the error was pressent. After setting those to "None", the error goes away.

  8. B482b83ec99d9495ddc16dd05cd29044?d=mm

    ImperativeGames

    Mar 14, 2017 12:12

    Workaround is not looking in log or what? Very hard to debug...

  9. 54f1337465050314bc8643166dea02e7?d=mm

    TheMasonX

    Mar 11, 2017 06:53

    I take it there's still no workaround? Also, does anybody know what (if anything) this actually breaks/prevents from occuring? I've only seen it in a fresh project I'm using to test some Leap Motion ideas. I've had it since I first tried to play, but no trace and no context mean no idea why it's happening, and things seem to be working alright enough that I'm unsure if anything isn't working or if it's just logging errors.

  10. D5b735ddeef22e977815888980e8813d?d=mm

    Kopter

    Mar 10, 2017 14:34

    Had this start happening in b10, still there in b11.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.